Exotel Status Board
Home
Dashboard
BETA
4th October 2021
Mumbai
Issue observed for 'Outgoing Calls' in Mumbai Region
Identified at [04/10/21 01:45 PM] with 'Major Outage'
Issue has been resolved at [04/10/21 01:50 PM]