BETA

4th October 2021

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [04/10/21 12:40 PM] with 'Major Outage'

Issue has been resolved at [04/10/21 12:45 PM]