BETA

4th October 2021

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [04/10/21 11:45 AM] with 'Partial Outage'

Issue has been resolved at [04/10/21 12:18 PM]