Exotel Status Board
Home
Dashboard
BETA
4th October 2021
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [04/10/21 10:35 AM] with 'Major Outage'
Issue has been resolved at [04/10/21 10:40 AM]