Exotel Status Board
Home
Dashboard
BETA
3rd October 2021
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [03/10/21 08:25 PM] with 'Major Outage'
Issue has been resolved at [03/10/21 08:30 PM]