BETA

30th September 2021

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [30/09/21 01:51 PM] with 'Partial Outage'

Issue has been resolved at [30/09/21 01:55 PM]