BETA

25th September 2021

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [25/09/21 04:05 PM] with 'Partial Outage'

Issue has been resolved at [25/09/21 04:20 PM]