Exotel Status Board
Home
Dashboard
BETA
4th September 2021
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [04/09/21 11:15 AM] with 'Major Outage'
Issue has been resolved at [04/09/21 11:20 AM]