Exotel Status Board
Home
Dashboard
BETA
4th September 2021
Indonesia
Issue observed for 'Incoming Calls' in Indonesia Country
4 years ago
Identified at [04/09/21 01:50 AM] with 'Major Outage'
Issue has been resolved at [04/09/21 02:10 AM]