BETA

17th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [17/03/19 09:51 AM] with 'Partial Outage'

Issue has been resolved at [17/03/19 09:53 AM]