Exotel Status Board
Home
Dashboard
BETA
28th August 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [28/08/21 10:30 AM] with 'Major Outage'
Issue has been resolved at [28/08/21 10:35 AM]