Exotel Status Board
Home
Dashboard
BETA
18th August 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [18/08/21 01:36 PM] with 'Major Outage'
Issue has been resolved at [18/08/21 02:00 PM]