Exotel Status Board
Home
Dashboard
BETA
12th August 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [12/08/21 05:00 AM] with 'Major Outage'
Issue has been resolved at [12/08/21 05:25 AM]