Exotel Status Board
Home
Dashboard
BETA
9th August 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [09/08/21 12:55 AM] with 'Major Outage'
Issue has been resolved at [09/08/21 01:21 AM]