Exotel Status Board
Home
Dashboard
BETA
8th August 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [08/08/21 02:15 AM] with 'Major Outage'
Issue has been resolved at [08/08/21 02:50 AM]