BETA

29th July 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [29/07/17 09:15 AM] with 'Major Outage'

Issue has been resolved at [29/07/17 09:16 AM]