Exotel Status Board
Home
Dashboard
BETA
29th July 2021
Gujarat
Issue observed for 'Outgoing Calls' in Gujarat Region
Identified at [29/07/21 04:00 PM] with 'Major Outage'
Issue has been resolved at [29/07/21 07:55 PM]