BETA

29th July 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [29/07/17 09:15 AM] with 'Partial Outage'

Issue has been resolved at [29/07/17 09:16 AM]