BETA

6th July 2021

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [06/07/21 01:01 PM] with 'Major Outage'

Issue has been resolved at [06/07/21 01:45 PM]