Exotel Status Board
Home
Dashboard
BETA
6th July 2021
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [06/07/21 10:16 AM] with 'Major Outage'
Issue has been resolved at [06/07/21 10:25 AM]