Exotel Status Board
Home
Dashboard
BETA
3rd July 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [03/07/21 09:50 AM] with 'Major Outage'
Issue has been resolved at [03/07/21 10:35 AM]