BETA

28th July 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [28/07/17 12:47 PM] with 'Partial Outage'

Issue has been resolved at [28/07/17 12:50 PM]