BETA

26th July 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [26/07/17 11:49 AM] with 'Major Outage'

Issue has been resolved at [26/07/17 11:51 AM]