BETA

12th June 2021

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [12/06/21 05:34 AM] with 'Partial Outage'

Issue has been resolved at [12/06/21 06:15 AM]