BETA

22nd July 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [22/07/17 12:50 PM] with 'Major Outage'

Issue has been resolved at [22/07/17 01:04 PM]