BETA

9th August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [09/08/16 12:42 AM] with 'Major Outage'

Issue has been resolved at [09/08/16 12:44 AM]