BETA

17th March 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [17/03/19 06:41 AM] with 'Partial Outage'

Issue has been resolved at [17/03/19 06:44 AM]