BETA

21st July 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [21/07/17 12:44 AM] with 'Partial Outage'

Issue has been resolved at [21/07/17 12:45 AM]