BETA

25th May 2021

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [25/05/21 01:49 AM] with 'Partial Outage'

Issue has been resolved at [25/05/21 01:50 AM]