BETA

21st July 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [21/07/17 12:44 AM] with 'Major Outage'

Issue has been resolved at [21/07/17 12:45 AM]