BETA

17th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [17/03/19 06:30 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [17/03/19 06:39 AM]