BETA

20th May 2021

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [20/05/21 06:25 PM] with 'Partial Outage'

Issue has been resolved at [20/05/21 06:35 PM]