BETA

13th July 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [13/07/17 01:22 AM] with 'Partial Outage'

Issue has been resolved at [13/07/17 01:24 AM]