BETA

8th August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [08/08/16 04:56 PM] with 'Partial Outage'

Issue has been resolved at [08/08/16 04:58 PM]