BETA

15th May 2021

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [15/05/21 08:59 AM] with 'Partial Outage'

Issue has been resolved at [15/05/21 09:05 AM]