BETA

29th June 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [29/06/17 06:25 AM] with 'Major Outage'

Issue has been resolved at [29/06/17 06:26 AM]