Exotel Status Board
Home
Dashboard
BETA
11th May 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [11/05/21 02:00 AM] with 'Major Outage'
Issue has been resolved at [11/05/21 02:20 AM]