Exotel Status Board
Home
Dashboard
BETA
11th May 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
4 years ago
Identified at [11/05/21 01:24 AM] with 'Major Outage'
Issue has been resolved at [11/05/21 01:35 AM]