Exotel Status Board
Home
Dashboard
BETA
8th May 2021
Mumbai
Issue observed for 'Outgoing Calls' in Mumbai Region
Identified at [08/05/21 08:45 AM] with 'Major Outage'
Issue has been resolved at [08/05/21 10:10 AM]