BETA

6th May 2021

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country
4 years ago

Identified at [06/05/21 12:35 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [06/05/21 02:40 PM]