BETA

28th April 2021

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [28/04/21 11:10 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/04/21 11:20 PM]