BETA

15th April 2021

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [15/04/21 06:25 AM] with 'Partial Outage'

Issue has been resolved at [15/04/21 06:30 AM]