BETA

17th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [17/03/19 06:02 AM] with 'Partial Outage'

Issue has been resolved at [17/03/19 06:03 AM]