BETA

8th August 2016

Incoming SMS Issue observed for Incoming SMS across India

Identified at [08/08/16 07:47 AM] with 'Partial Outage'

Issue has been resolved at [08/08/16 07:48 AM]