Exotel Status Board
Home
Dashboard
BETA
9th April 2021
West Bengal
Issue observed for 'Incoming Calls' in West Bengal Region
Identified at [09/04/21 04:49 PM] with 'Major Outage'
Issue has been resolved at [09/04/21 05:35 PM]