BETA

9th April 2021

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [09/04/21 12:05 PM] with 'Major Outage'

Issue has been resolved at [09/04/21 12:30 PM]