Exotel Status Board
Home
Dashboard
BETA
8th April 2021
West Bengal
Issue observed for 'Incoming Calls' in West Bengal Region
Identified at [08/04/21 12:55 PM] with 'Major Outage'
Issue has been resolved at [08/04/21 01:20 PM]