BETA

30th March 2021

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [30/03/21 10:35 PM] with 'Partial Outage'

Issue has been resolved at [31/03/21 12:05 AM]