BETA

26th March 2021

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [26/03/21 10:35 AM] with 'Major Outage'

Issue has been resolved at [26/03/21 10:40 AM]