BETA

23rd March 2021

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [23/03/21 02:10 PM] with 'Partial Outage'

Issue has been resolved at [23/03/21 02:15 PM]